
USB Forensic Tracker v1.0.7  

© 2015-2017 Andrew Smith, Orion Investigations Co Ltd                                                                                                  

Introduction 

USB Forensic Tracker (USBFT) is a comprehensive forensic tool that extracts USB device connection 

artefacts from a range of locations within the live system, from mounted forensic images, from 

extracted Windows system files and from both extracted Mac OSX and Linux system files. The extracted 

information from each location is displayed within its own table view.  The information can be exported 

to an Excel file.  

 

 

 

USBFT extracts information from the following locations: 

Windows 

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR 

 HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices 

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceClasses 

 HKEY_USERS\SID\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2 

 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList 

 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices 

 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\VolumeInfoCache 

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SWD\WPDBUSENUM 

 Microsoft-Windows-DriverFrameworks-UserMode/Operational Event Log (Windows 7) 

 Microsoft-Windows-Storage-ClassPnP/Operational.evtx Event Log (Window 10) 
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 Microsoft-Windows-WPD-MTPClassDriver/Operational.evtx 

 C:\Windows\inf\setupapi.dev.log 

 C:\Windows\setupapi.log 

 “Windows.old” folder 

 

Mac OSX (tested on OSX 10.6.8 and 10.10.3) 

1) /private/var/log/kernel.log 

2) /private/var/log/kernel.log.incrementalnumber.bz2 

3) /private/var/log/system.log 

4) /private/var/log/system.log.incrementalnumber.gz 

 

Linux (tested on Ubuntu 17.04) 

1) /var/log/syslog 

 

Requirements 

USBFT requires Net Framework 4.5 to be installed on the system.  

 

Instructions 

 Window Live System  

1) To run USBFT on a live Windows system, open USBFT and press the “Run” button 

2) Make sure you run the 64 bit version on a 64 bit machine. If you run the 32 bit version it will not 

extract all of the USB artefacts. 

3) USBFT will automatically extract information from the registry, selected event logs if they are 

present and the setupapi.log (or setupapi.dev.log). Each table corresponding to extraction 

location will be populated.  

4) Status messages will be displayed at bottom of GUI. 

5) By default USBFT will display time stamps in local time. From the “Options => Time Settings” 

menu, the user can select either local time or UTC. Change the time zone before running USBFT. 

6) From the “Options => Date Format menu, the user can select how the date stamps will be 

displayed”. Set the format prior to running the tool.         

7) The user has the option to export all records to Excel spreadsheet. When exporting to Excel each 

of the table views will be placed into its own work sheet.  
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8) USBFT will also extract USB artefacts from the “Windows.old” folder. To extract the artefacts 

select “C:\” from the dropdown menu and press the run button. 

 

9) Within the “Windows.old” folder USBFT will examine all the same files as for the live system. 

Extracting USB artefacts from a mounted forensic image 

1) USBFT can analyze either mounted forensic images or additional connected hard drives that 

contain a Windows OS. 

2) The forensic image must be mounted as WRITABLE otherwise the registry hives will not load. 

3)  Once the forensic image has been mounted, open USBFT and from the drop down list select the 

drive letter that corresponds to the volume that contains the Windows OS.  

4) Once selected USBFT will automatically locate and temporarily load the required registry hives 

into the registry of the examination machine. Once the files have been loaded press the run 

button to begin the extraction.  

5) When you close USBFT the loaded registry files will be automatically unloaded from the registry 

before closing USBFT. If USBFT is interrupted during this process and as a result doesn’t cleanly 

remove all temp registry files, just open and close USBFT again and it will clear the registry. 

6) USBFT will automatically locate all the required files within the mounted image and extract the 

artefacts the same as for a live system. In addition USBFT will automatically search for the 

“Windows.old” and extract the USB artefacts without any additional steps.  

 

Extracting USB artefacts from extracted Windows files 

 USBFT now has the option to process Window files that have been saved to a custom folder. The 

registry files and Window logs can be saved to the root of the folder. However to process all the 

NTUser.dat files for each user accounts requires the NTUser.dat files to be saved in a specific folder 

structure as shown below: 

 Custom Folder 

 Registry File – Software 

 Registry File – System 

 Microsoft-Windows-DriverFrameworks-UserMode/Operational Event Log (Windows 7) 

 Microsoft-Windows-Storage-ClassPnP/Operational.evtx Event Log (Window 10) 

 Microsoft-Windows-WPD-MTPClassDriver/Operational.evtx 

 setupapi.dev.log 

 Users (directory) 

 UserProfile1 (directory) 

 NTUser.dat 

 UserProfile2 (directory) 

 NTUser.dat 
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 UserProfile3 (directory) 

 NTUser.dat 

The name of the “UserProfile” folder should have the same name as the sub folders in the Users folder 

on the system under examination. 

 

Extracting USB artefacts from extracted Mac OSX files 

1) USBFT can now extract USB artefacts from kernel.log, kernel.log.incrementalnumber.bz2, 

system.log and system.log.incrementalnumber.gz Mac OSX files.  

2) Extract the required files to a folder on the Windows examination machine. 

3) Open USBFT and press the MAC Analysis button.  

4) Select the folder containing the required files and click   OK. 

5) When you click OK, the extraction process will begin automatically. Do not press the “Run” 

button. 

 

Extracting USB artefacts from extracted Linux files 

1) USBFT can extract USB artefacts from Ubuntu syslog files 

2) Extract the required files to a folder on the Windows examination machine. 

3) Open USBFT and press the Linux Analysis button.  

4) Select the folder containing the required files and click   OK. 

5) When you click OK, the extraction process will begin automatically. Do not press the “Run” 

button. 

 

Extracting serial number from a connected USB device 

The user now has the option to connect a USB device to a computer and extract the serial number. 

1) Connect a USB device to the computer. 

2) Click the USB button  

3) A form will open 

4) Enter the drive letter of the USB device followed by : into the form. 
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5) Click “Get Serial Number”. 

6) You can click “Copy to Clipboard” button to save the serial number. 

 

Exporting data to Excel spreadsheet 

1) By default when you export the data, the content of all the data grids will be exported into a 

single Excel spreadsheet.  

2) Occasionally a data grid may contain characters that is not compatible with Excel. Once the data 

has been exported to Excel when you try to open the spreadsheet you will receive an error 

message and will be unable to open the spreadsheet.  

3) If this occurs you can identify which data grid contains the illegal characters by going to Options 

=> Export Options and deselecting the data grids one at a time until you identify the problem.  

 

A 32bit and 64 bit version of USB Forensic Tracker is included in the download. If you run the 32 bit 

version on a 64 bit machine, USBFT will not display the results for the Event Log artefacts or for 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices. 

From the “Help” menu the user can check for updates. 

 

Time Stamp Information:  

Many of the time stamps are obtained from the last written time stamp of the registry keys.  

SOFTWARE\Microsoft\Windows Portable Devices\Devices 

Last Written Date is created when pen drive first connected 
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Last Written Date is not updated each time the pen drive is connected and is assigned the same 

drive letter as previously assigned 

Last Written Date will update when the pen drive is connected and assigned a new drive letter 

SYSTEM\CurrentControlSet\Enum\USBSTOR 

Last Written Date is created when pen drive first connected 

Last Written Date is not updated each time the pen drive is connected 

Microsoft-Windows-DriverFrameworks-UserMode/Operational Event Log 

Time Date stamps reflects each time the pen drive is connected or disconnected from the 

system 

Microsoft-Windows-Storage-ClassPnP/Operational.evtx Event Log 

Time Date stamps reflects each time the pen drive is connected to the system 

 

License 

This utility is released as freeware. You are allowed to freely distribute this program via any method, as 

long as you don't charge anything for this. If you distribute this utility, you must include all files in the 

distribution package, without any modification! 

Icons by Everaldo Coelho from the Crystal project are used; these are released under the LGPL license. 

 

Disclaimer 

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not 

limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will 

not be liable for any special, incidental, consequential or indirect damages due to loss of data or any 

other reason. 

 

Version 1.0.7 August 2017 

1) USBFT now supports the extraction of USB artefacts from Linux (Ubuntu) syslog files 

2) Added styling and formatting to the Excel report 

 

 

http://www.everaldo.com/
http://www.gnu.org/licenses/lgpl.html
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Version 1.0.6 August 2017 

1) USBFT now extracts data from the registry  key 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SWD\WPDBUSENUM 

2) Setupapi Log – changed the name of the “Connection Date” column to “Device Install Date”.   

3) Added a new column called “Device Delete Date”. USBFT extracts the time and date when the 

device drivers are installed for a USB device (typically the first time it is connected).  

4) USBFT now displays the time and date when the Windows Plug and Play Cleanup service deletes 

the drivers for a USB device and deletes the entries for the device from the registry. The time 

and date is displayed in the “Device Delete Date” column. 

 

Version 1.0.5 July 2017 

1) Changed the project over from Windows Forms to WPF MVVM to make it easier to maintain and 

update in the future. 

2) Made major changes to the code throughout the project to accommodate the new format. 

3) Added the ability to process a custom folder that contains the extracted Windows registry files, 

Windows logs and NTUser.dat files 

4) Added the ability to extract USB artefacts from the “Windows.old” folder. 

5) Added the ability to extract USB artefacts from 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\VolumeInfoCache 

6) Added the ability for a user to extract the serial number of a USB device connected to the 

system. 

7) Made changes to the title of the Win7 and Win10 Event Log tabs. 

8) Added an EventID column to the Windows7 Event Log data grid and the Win10 Event Log data 

grid. 

9) Removed the checkbox column from the data grids. 

10) Removed the filter button from the menu (used to filter checked files). 

11) Removed the Reload button ( now redundant)  

12) Under Options => Export Options, added the ability for the user to select which data grids will be 

exported to the excel spreadsheet.  

13) Combined all the DLL’s with the exe to make a single exe file for ease of deployment. 

Version 1.0.4 July 2016 

1) Made a slight change to the code and to the README file to make it clear that when analyzing 

mounted forensic images they must be mounted in writable mode.  

 

 



USB Forensic Tracker v1.0.7  

© 2015-2017 Andrew Smith, Orion Investigations Co Ltd                                                                                                  

Version 1.0.3 November 2015 

1) Added additional support for Mac OSX files. USBFT will now also process kernel.log and 

kernel.log.incrementalnumber.bz2 files 

2) Modified code for USBSTOR section. For devices such as multi card readers that show as 

multiple drives with different drive letters but the same serial number, USBFT will now correctly 

display all of the drive letters. 

3) Renamed the “Last Connection Date” column in the Device Classes section to “Connection Date” 

Version 1.0.2 November 2015 

1) Added the ability to extract USB artefacts from mounted forensic images. 

2) Added the ability to extract USB artefacts from Mac OSX system files 

3) Made changes to code relating to obtaining the last modified date of registry keys 

4) Other minor changes made to some of the code to make more robust 

Version 1.0.1 September 2015 

1) USBFT now parses the Microsoft-Windows-Storage-ClassPnP/Operational.evtx event log 

(Window 10) and the Microsoft-Windows-WPD-MTPClassDriver/Operational.evtx event log. 

Limited information can be extracted from the Microsoft-Windows-WPD-

MTPClassDriver/Operational.evtx event log but it does indicate when a Media Transfer Protocol 

(MTP) portable device has been connected to the computer.  

2) Under the “Options” button added the ability for a user to set the format for the date stamps.  

3) Made a slight change to the code so USBFT now displays the correct user SID in the Source 

column of the Registry-Mountpoints2 table view. 


